Performance degradation with pull request diffs
Incident Report for Atlassian Bitbucket
Resolved
This incident has been resolved.
Posted Jul 02, 2021 - 15:40 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 02, 2021 - 15:40 UTC
Monitoring
A fix for diff caching has been deployed to production, and we will continue to monitor for errors.
Posted Jul 02, 2021 - 06:20 UTC
Update
At 6:31PM UTC on July 1st, we disabled some diff caching logic that we suspect was contributing to a higher pull request error rate for some customers. We are currently deploying a patch that should fix this permanently, however if you are still experiencing errors, watch this Statuspage for updates.
Posted Jul 02, 2021 - 01:01 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 01, 2021 - 20:20 UTC
Update
We continue to work on resolving errors generating diffs on pull requests. We have identified the root cause and expect recovery shortly. Next update in 1 hour.
Posted Jul 01, 2021 - 19:22 UTC
Investigating
We are investigating cases of degraded performance for viewing pull request diffs Atlassian Bitbucket Cloud customers. We will provide more details as soon as we have more information
Posted Jul 01, 2021 - 12:07 UTC
This incident affected: Website and API.