Bitbucket - Steps are queued and delayed from starting

Incident Report for Atlassian Bitbucket

Resolved

On May 30th, there was an issue where Bitbucket pipeline steps were queued and delayed from starting. This problem has now been resolved, and the service operates normally for all customers.
Posted May 30, 2025 - 15:00 UTC

Monitoring

The Bitbucket issues, where steps were queued and delayed, have been mitigated. Services are now functioning normally for all affected customers.
We will monitor it closely to ensure stability.
Posted May 30, 2025 - 14:44 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 30, 2025 - 14:08 UTC

Investigating

We are investigating an issue affecting Bitbucket, where steps are queued and delayed from starting.
Our team is working diligently to resolve this issue and restore services as quickly as possible.

We'll keep you posted with further updates.
Posted May 30, 2025 - 13:42 UTC
This incident affected: Pipelines.