Repository archive downloads disrupted (affecting AWS CodePipeline)
Incident Report for Atlassian Bitbucket
Resolved
We have confirmation from customers and from our internal monitoring that the issue has been resolved.
Posted Jan 12, 2022 - 23:16 UTC
Update
We are continuing to monitor for any further issues.
Posted Jan 12, 2022 - 23:13 UTC
Monitoring
We have deployed a fix that we believe should fix the issue affecting repository archive downloads, and we see error rates returning to healthy levels. We also believe this should resolve the issue causing builds to fail in AWS CodePipeline and have reached out to customers to confirm.

We'll keep monitoring our systems a bit longer to ensure archive downloads continue to work as expected.
Posted Jan 12, 2022 - 23:00 UTC
Identified
We have determined that a percentage of users attempting to download repository archives are encountering errors, and we believe this is responsible for the CodePipeline failures that have been reported.

For now we recommend a workaround of switching to the "Full clone" option in AWS CodePipeline to get builds working again. Meanwhile our engineering team is working to resolve the issue affecting repository archive downloads.
Posted Jan 12, 2022 - 22:30 UTC
Investigating
We've received reports from users of AWS CodePipeline that their builds are failing to authenticate when attempting to access Bitbucket repositories. We're investigating the issue and will provide further updates shortly.
Posted Jan 12, 2022 - 21:04 UTC
This incident affected: Source downloads.