Increased latency merging pull requests
Incident Report for Atlassian Bitbucket
Resolved
We are currently in the process of upgrading our repository infrastructure
which can result in additional latency with merges. Rest assured, if you are experiencing slow merges, your pull requests will be merged successfully.

After initiating a merge request the merge will be processed in the background. This typically only takes a few seconds but may take longer. You can safely navigate away, and the status of the pull request will be updated once it is merged.

Also, today we added a notification to the pull request screen explaining how merges are being processed asynchronously now.
Posted Jun 28, 2021 - 23:26 UTC
Identified
We are investigating cases of degraded performance for some Atlassian Bitbucket Cloud customers. We are currently in the process of upgrading our repository infrastructure which can result in additional latency with certain git operations. Rest assured, if you are experiencing slow merges, your pull requests will be merged successfully. We are working on mitigations to improve performance. Follow this statuspage for updates.
Posted Jun 28, 2021 - 11:21 UTC
This incident affected: Website.